PDA

View Full Version : Mud Pump



Brian S
10-05-2012, 11:52 AM
I have had a little problem with the pump, it is very stiff to pump when filling the boxes, pumping mud, but not a problem when clean and not pumping mud.

I have given it a good cleaning, the mesh at the bottom is clean, it still does it

Any ideas!!

Beermonster
10-05-2012, 03:45 PM
I have had a little problem with the pump, it is very stiff to pump when filling the boxes, pumping mud, but not a problem when clean and not pumping mud.

I have given it a good cleaning, the mesh at the bottom is clean, it still does it

Any ideas!!

I think u need 2 get into the inside of it as i do believe its the plate!
What kind of pump is it?

Brian S
10-05-2012, 04:17 PM
Its a Drywall Master

Beermonster
10-05-2012, 04:37 PM
Its a Drywall Master
I have blueline and columbia pumps and if things start going stiff its 100% its the plate inside that is bent or broken!
I would say 2 get a pump kit for it and take the thing apart! But make sure u get the plate or plates for the inside as sometimies u just get a bunch of seals for them!
My columbia kept going for years and then it did the same thing,stiff as f*ck and yea it was the plates inside. Its an easy job but it took me a while 2 get the plates apart!
Give Marcus a shout he will sort u out!

Brian S
10-05-2012, 04:54 PM
:fing02: Cheers mate

Beermonster
10-05-2012, 04:57 PM
:fing02: Cheers mate

No probs lad!
Glad 2 help,if u get stuck pm me and i will c if i can help u out!