PDA

View Full Version : nilfisk alto



wallpaul
09-02-2014, 12:24 PM
anyone use or used a nilfisk alto aero 26-21 pc hoover?
found one for a decent price.

bought a edx from belmore but giving me grief!

forestbhoy
09-02-2014, 08:12 PM
Had one for about 5 years now,and touch wood,pretty bomb proof. Got it from w and c with my first flex. Still going strong even though i have not done anything to it.

belmoreboy
09-02-2014, 09:34 PM
Hi Paul what's up with your edx? How old is it?

E.K Taper
10-02-2014, 01:50 AM
We hire our sander/Hoover from Artex and after having loads of hassle with the Sparky vacs they sent us the Nilfisk Alto. Great Hoover we never had a problem with it

DMC
10-02-2014, 06:29 PM
Have been supplied a nilfisk from the company im currently slaving for, good piece of kit has proven to be totally reliable to date

wallpaul
12-02-2014, 01:41 PM
Hi Paul what's up with your edx? How old is it?

marcus, tried phoning but you are away for a couple of weeks.
like i said before it sounds like a jumbo jet? cleaned it out with a hoover,then it kept cutting out?! got a sparky too look at it for me.
took the face off and there was dust all inside the sealed unit? surely it should have a seal of some sort but it does not!
the cable had a break where the double insulated lead is at the bottom.
fixed that and started using it and smelt burning, stopped and opened it up and the diaphragm had stuck to the top unit!??!

all in all started as a really good bit of kit,but has become a pain in the arse!!

Beermonster
12-02-2014, 03:43 PM
marcus, tried phoning but you are away for a couple of weeks.
like i said before it sounds like a jumbo jet? cleaned it out with a hoover,then it kept cutting out?! got a sparky too look at it for me.
took the face off and there was dust all inside the sealed unit? surely it should have a seal of some sort but it does not!
the cable had a break where the double insulated lead is at the bottom.
fixed that and started using it and smelt burning, stopped and opened it up and the diaphragm had stuck to the top unit!??!

all in all started as a really good bit of kit,but has become a pain in the arse!!
I have 1 of those 2!
Had a problem at the start with it and sent it back,It had a snapped cable inside!
Then when running it off my flex it would start and stop,then it stopped that carry on and its been fine since then!
Im also running the sander now and its not missed a beat since!!

E.K Taper
12-02-2014, 06:12 PM
We hire our sander/Hoover from Artex and after having loads of hassle with the Sparky vacs they sent us the Nilfisk Alto. Great Hoover we never had a problem with it
Until now:(
It's doing the jumbo jet thing and also cuts out all the time. You get 30seconds then it cuts out for 30seconds! Going to exchange it tomorrow