Results 1 to 4 of 4
  1. #1
    Member
    Join Date
    Mar 2010
    Posts
    36
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default Columbia Bazooka Help

    drywallschool.com

    Hello,

    Basically we've been hand taping for ages now and after our previous taping Bazooka got stolen before we had chance to use it, we've punted for a new one ( well 2nd hand ) hopefully to speed us up a bit .

    To cut a long story short we started a job today pumped the bazooka full of mud and when i flicked the clutch back over the mud wouldn't coat the paper tape , the plunger was not being drawn down , am i fogeting to do something ? or is the cable or whatever is attached to the plunger not working or snapped ? I manage to empty the bazooka by pushing the plunger down with my pole sander handel , i've now cleaned it all , waitig for your instructions ; )

  2. #2
    Season ticket holder amestaper's Avatar
    Join Date
    Dec 2008
    Location
    Edinburgh
    Posts
    2,612
    Thanks Thanks Given 
    425
    Thanks Thanks Received 
    282
    Thanked in
    227 Posts

    Default

    You've established theres no blockage in the tube and you engaged the gear so if it's a new gun I doubt the cables broken so it has probably just come loose inside the head where it connects to the cable drum and truss head screw.

    You will have to take the top plate off, and if the cable pulls right out you will also have to take the bottom ring off also for access to the plunger from the bottom. The cable cant come loose at the bottom (on my brand anyway), but I have seen them break if the muds too thick. Re-attach or renew the cable and screw the plate and ring back on.

    Should only be a 10 minute job.
    Your messages are really important to us
    ...but not important enough to employ a sufficient number of support staff to answer them.

  3. #3
    Season ticket holder amestaper's Avatar
    Join Date
    Dec 2008
    Location
    Edinburgh
    Posts
    2,612
    Thanks Thanks Given 
    425
    Thanks Thanks Received 
    282
    Thanked in
    227 Posts
    Your messages are really important to us
    ...but not important enough to employ a sufficient number of support staff to answer them.

  4. #4
    Member
    Join Date
    Mar 2010
    Posts
    36
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    Default

    thanks the cable had broken next to the plunger , i removed bottom ring and unwound cable and reconnected it at the plunger end .

    thanks for the help

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Columbia bazooka problem
    By Kenya get over this in forum Taping tools and materials
    Replies: 5
    Last Post: 20-07-2013, 01:49 PM
  2. Hardened by columbia
    By Singing jointer in forum Classifieds
    Replies: 1
    Last Post: 24-05-2013, 10:19 PM
  3. Columbia finishing set
    By Singing jointer in forum Taping tools and materials
    Replies: 25
    Last Post: 27-07-2012, 06:07 PM
  4. Need help with columbia taper
    By snappy in forum Taping tools and materials
    Replies: 31
    Last Post: 01-09-2011, 10:58 AM
  5. Need help with columbia taper
    By snappy in forum Taping, jointing and drywall finishing
    Replies: 5
    Last Post: 26-08-2011, 04:10 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •